Unable to build with qt 5.8 on ArchLinux amd64

Hello, I'm unable to build webissues client on ArchLinux amd64 with qt 5.8.0 and gcc 6.3.1. Log: https://paste.pztrn.name/1850/.

Re: Unable to build with qt 5.8 on ArchLinux amd64

Hello,

Try editing src/dialogs/dialogs.pri in the following way:

#contains( QT_CONFIG, openssl ) | contains( QT_CONFIG, openssl-linked ) {
    HEADERS += dialogs/ssldialogs.h
    SOURCES += dialogs/ssldialogs.cpp
#}

Regards,
Michał

Re: Unable to build with qt 5.8 on ArchLinux amd64

Yep, that worked, thanks. Done same thing in src/data/data.pri and everything compiles now.

Can you please include this fix (and http://webissues.mimec.org/node/891) and release a new version? Looks like webissues client will not compile normally on Qt 5.6+.

Re: Unable to build with qt 5.8 on ArchLinux amd64

Yes, I will do that. I just have to find a proper solution for this as commenting out these lines was just a workaround.

Regards,
Michał