openSUSE Leap 42.2 - tips for building and installing from source

I just want to share some general tips for building webissues-1.1.4 client on Leap 42.2 with Qt 5.6.1 (might be useful also for other distros).

Before you start don't forget to install the following packages:
- libqt5-qtbase-devel (provides qmake-qt5)
- libQt5WebKit5
- libQt5WebKit5-devel

Important - edit file: webissues-1.1.4/src/commands/command.h
... and add the following line after #include (line28):

class QIODevice;

When running configure make sure you specify path to qmake:

./configure -qmake /usr/lib64/qt5/bin/qmake

(use additional options from INSTALL file as required)

If you complete above steps you shouldn't have any problems with building and installing.

make
sudo make install

Hope this helps you somehow :)