client build-problems

Submitted by Anonymous (not verified) on 2007-09-24

Dear WebIssues user,

I'm very new to that forums and to WebIssues and have my first big problem. - I hope you can help me out:
- I downloaded Version 0.9.1 for Linux (I use Gentoo)
- unpacked the sources to /tmp/webissues-0.9.1
- went into /tmp/webissues-0.9.1
- tried "cmake src/"
- ended up with the error-message:
# cmake src/
CMake Error: Error in cmake code at
Unknown CMake command "QT4_AUTOMOC".
-- Configuring done

After googleing I couldn't solve that problem by myself. - I tried cmake version 2.4.6-r1 and 2.4.7-r1 with the same result... :(

Moreover I have a question:
Is there a (simple - maybe only vor viewing) Web-Interface? - I think it would be a nice feature!

I also tried Version 0.9.2-beta2 - same error-message... :(

Thanks a lot for your attention!


Please go to the webissues directory and run:

cmake .

If you run cmake only in the src/ subdirectory it won't have the Qt4 package included.

Regarding the web interface - I agree that it would be very nice. But unless I find someone who's willing to do it, it's very unlikely to happen in the nearest future.